New spam blocking

48 posts / 0 new
Last post
Mike Harman
Offline
Joined: 7-02-06
Sep 25 2011 14:04
New spam blocking

I've installed Mollom. This does textual analysis of comments, hits you with a captcha if it thinks it's spam.

I'm hoping it'll be more effective/less annoying than the current captcha, we'll see.

More importantly, once you've posted more than 5 comments, it's automatically disabled - so regular users won't get captchas any more. We might need to up that threshold if we still get a lot of spam come through.

ultraviolet's picture
ultraviolet
Offline
Joined: 14-04-11
Sep 25 2011 17:20

Hi, it's glitching for me. I tried to edit a post I wrote earlier today and was forbidden to proceed until I filled out the "captcha" (I'm assuming that's the thing with the letters you have to copy?) -- the problem was although there was a prompt instruction me to do this, there was NO captcha to be seen! So I could not fill in the letters as there were none! So I just pressed the "save" button again to post and then it said that my comment was detected as spam and would not be allowed to be posted! I tried again it happened the same way.

So I gave up on editting that comment and decided to post my edits in a new comment (not the entire comment again, just the thing I wanted to add) -- and again it said I was detected as spam and being blocked! I was able to post on another thread without trouble, but it seems for that particular thread I have been blocked from further comments?

It really sucked... I never had the old system cause any problems.

Also, I have about two-dozen posts... you said after 5 posts people aren't bothered with this captcha anymore... so I don't know why this is occuring.

I realize this is complicated technical stuff so I hope you don't interpret this as me berrating you... I'm frustrated but put no blame on you for the problem. I hope it can be fixed soon, though!

Mark.
Offline
Joined: 11-02-07
Sep 25 2011 23:36

So I've posted successfully on the Greece thread and then I'm being blocked from editing it.

Samotnaf
Offline
Joined: 9-06-09
Sep 26 2011 02:43

Had repeated problems with this, like ultraviolet. Defined as spam and blocked, then impossible to return to original page. I can't post stuff - a frustrating waste of time.

Mike Harman
Offline
Joined: 7-02-06
Sep 26 2011 05:18

Now you've posted a comment you should be removed from these checks.

I'm going to have it so spam posts get put into moderation rather than blocked for now, so it doesn't completely lock people out.

Samotnaf
Offline
Joined: 9-06-09
Sep 26 2011 06:24

Though I'd already posted a comment, it still didn't work. Did it just now again (a quote from the Wall St. Journal about China), and it's being sent in for moderation. Does this mean that all posts are now going to be pre-moderated or what? And if so, that's an enormous amount of work for admin.
PS Does having a red star (*) by "Comment:", which I now have, have anything to do with it?

PPS Though I've posted some comments since this new spam controller was brought in, I still have to do a Mollom version of captcha to post this, even though I didn't log out (and even again, after editing).

Mike Harman
Offline
Joined: 7-02-06
Sep 26 2011 06:47

test

Mike Harman
Offline
Joined: 7-02-06
Sep 26 2011 06:49

test

Mike Harman
Offline
Joined: 7-02-06
Sep 26 2011 06:51

test again

Mike Harman
Offline
Joined: 7-02-06
Sep 26 2011 06:53

bb

Mike Harman
Offline
Joined: 7-02-06
Sep 26 2011 06:56

test

Mike Harman
Offline
Joined: 7-02-06
Sep 26 2011 06:57

OK a bit of testing and I found the bug. I can fix this later today easily enough.

Battlescarred
Offline
Joined: 27-02-06
Sep 26 2011 08:41

Yep, I had a lot of problems too. Willtry and post today.

Mike Harman
Offline
Joined: 7-02-06
Sep 26 2011 11:07

May be fixed now, testing again.

petey
Offline
Joined: 13-10-05
Sep 26 2011 13:08

i've logged on and posted twice today with no spam check at all

no1
Offline
Joined: 3-12-07
Sep 26 2011 14:11

the top page in bookmarks is 'Access denied' - http://libcom.org/403

Mike Harman
Offline
Joined: 7-02-06
Sep 27 2011 13:11

No one has posted or pm'ed me about this going wrong. Some spam is still getting through (which was expected). Does this mean you're all locked out or it's working now?

Anarchia's picture
Anarchia
Offline
Joined: 18-03-06
Sep 28 2011 14:26

I'm still getting the captcha every single time I post - no problems with blocking, if I enter the captcha correctly then it posts, but its annoying - I've got hundreds of posts here so not sure why its still coming up for me?

888's picture
888
Offline
Joined: 30-09-03
Sep 30 2011 19:52

TEST

It's telling me i'm waiting moderator approval on the Bordiga on anarchism thread - why?

syndicalist
Offline
Joined: 15-04-06
Oct 1 2011 13:36

edited out - getting thru.

syndicalist
Offline
Joined: 15-04-06
Oct 1 2011 13:37

edited out - getting thru.

syndicalist
Offline
Joined: 15-04-06
Oct 1 2011 13:37

edited out

syndicalist
Offline
Joined: 15-04-06
Oct 1 2011 13:35

edit: seems like I can get thru now...yey!

Mike Harman
Offline
Joined: 7-02-06
Oct 1 2011 14:14

I had to manually put syndicalist in the 'regular user' role. Not sure why you got completely blocked by this sad

If anyone else is having trouble please don't just post comments - since enabling this and setting spammed comments to unpublished we have over 25,000 blocked comments sitting in a moderation queue, 99.9% of which is spam.

What you should do is pm any admin asking them to put you in the 'regular user' role, or e-mail admin at libcom dot org to do the same.

Steven.'s picture
Steven.
Offline
Joined: 27-06-06
Oct 2 2011 10:17
888 wrote:
TEST

It's telling me i'm waiting moderator approval on the Bordiga on anarchism thread - why?

I have manually made you a regular user so this shouldn't be a problem again

Mark.
Offline
Joined: 11-02-07
Oct 2 2011 10:30

Is there a risk here that people trying to post on libcom for the first time are getting blocked?

Joseph Kay's picture
Joseph Kay
Offline
Joined: 14-03-06
Oct 2 2011 11:01

It's a risk - but should now only be if they're failing captchas, which we had before. The problem with 888 and others was we set it to automatically exempt people with 5 or more posts from the anti-spam measures, but it didn't deal very well with people who already had more than that. In future new people will register as normal and post, if it looks like spam (links:text ratio, keywords) they'll get a captcha, if they pass that it will post and once they have five posts they will bypass the spam check. Human spammers that get through can be reported and blocked/deleted manually as before.

Mark.
Offline
Joined: 11-02-07
Oct 2 2011 11:15

Fair enough

Anatta's picture
Anatta
Offline
Joined: 22-06-11
Oct 3 2011 10:58

I'm having the same problems, getting a message saying

"Your submission has triggered the spam filter and will not be accepted."

My post was for the Occupy Manchester thread and contained URLs - don't if it is because of them?

Mike Harman
Offline
Joined: 7-02-06
Oct 3 2011 11:49

Yeah posts with URLs, especially lots of them will trigger it.

Did you get a captcha? Sometimes I think it will block posts without bothering with one.

Anatta's picture
Anatta
Offline
Joined: 22-06-11
Oct 3 2011 14:55
Mike Harman wrote:
Did you get a captcha? Sometimes I think it will block posts without bothering with one.

That's the authentification thing right? No I don't think there was one, just the message saying that my post was identified as spam.

http://www.youtube.com/watch?v=TmVxxH6tnh4&feature=feedwll&list=WL

yep, works ok now, cheers