Issues with the new theme

173 posts / 0 new
Last post
Armchair Anarchist's picture
Armchair Anarchist
Offline
Joined: 16-12-07
Apr 4 2012 19:22
Chilli Sauce wrote:
So has this gone live yet? Which version do non-members see when they visit the site?

'Old' version

Armchair Anarchist's picture
Armchair Anarchist
Offline
Joined: 16-12-07
Apr 4 2012 19:25
Mike Harman wrote:
Firebug has been broken on ff for me

1.9.1 is working for me with FF 11 smile

Felix Frost's picture
Felix Frost
Offline
Joined: 30-12-05
Apr 4 2012 21:30
Armchair Anarchist wrote:
Steven. wrote:
This thread for some reason is stretched and overlaps the right-hand column. I wonder if it might be because of the really long URL in one of the comments?

http://libcom.org/forums/organise/pay-cuts-social-care-27022012#new

It's nowt to do with the URL. If you take the #main-content {float: left;} style off it displays ok. The CSS needs a bit more investigation.

It still happens because of the long URL.

Cooked's suggestion of using word-wrap: break-word; is probably the easiest solution. You might also want to set a fixed width for the element you want to stop from expanding.

I also noticed another issue: You are cropping images in the right column using the css clip property, but this won't work in all browsers unless you also add overflow: hidden.

So here is what I would suggest (added code in bold):

#main-content {
float: left;
width: 640px;
word-wrap: break-word;

}

#sidebar .block .views-field-field-photo-fid {
position: relative;
margin-top: 6px;
margin-bottom: 6px;
height: 100px;
overflow: hidden;
}

Cooked's picture
Cooked
Offline
Joined: 6-04-10
Apr 4 2012 23:12
Felix Frost wrote:
So here is what I would suggest (added code in bold):
#main-content {
  float: left;
  width: 640px;
  word-wrap: break-word;
}

#sidebar .block .views-field-field-photo-fid {
  position: relative;
  margin-top: 6px;
  margin-bottom: 6px;
  height: 100px;
  overflow: hidden;
}

^does the trick

communal_pie's picture
communal_pie
Offline
Joined: 18-10-08
Apr 5 2012 00:03

I just downloaded the HTML of the "pay cuts in social care.." thread and set #main-content to width:100%.. for some reason this instantly fixes the issue of the #sidebar overflowing. Itried overflow:none on both of them but this did nothing.

-edit: oops, there is no such thing as "none" as a value for overflow..I was thinking of display..

-edit #2: just trying the smilies in this message, none of them seem to work on Safari 5

Chilli Sauce's picture
Chilli Sauce
Offline
Joined: 5-10-07
Apr 5 2012 22:45

So, I've had a bit of an issue that when I select on the 'unread posts' of a thread it takes me not to the the unread section of the thread, but a few posts before that.

Steven.'s picture
Steven.
Offline
Joined: 27-06-06
Apr 5 2012 23:03
Chilli Sauce wrote:
So, I've had a bit of an issue that when I select on the 'unread posts' of a thread it takes me not to the the unread section of the thread, but a few posts before that.

we are aware that that is a problem with comments after articles, but not in the forums. (If it was in the forums it could be due to images which hadn't fully loaded yet)

Armchair Anarchist's picture
Armchair Anarchist
Offline
Joined: 16-12-07
Apr 6 2012 12:33
Felix Frost wrote:
Armchair Anarchist wrote:
Steven. wrote:
This thread for some reason is stretched and overlaps the right-hand column. I wonder if it might be because of the really long URL in one of the comments?

http://libcom.org/forums/organise/pay-cuts-social-care-27022012#new

It's nowt to do with the URL. If you take the #main-content {float: left;} style off it displays ok. The CSS needs a bit more investigation.

It still happens because of the long URL.

So it does, apologies. Didn't realise URLs were unbreakable embarrassed

Chilli Sauce's picture
Chilli Sauce
Offline
Joined: 5-10-07
Apr 6 2012 13:46

Ah, yes, it's been in articles and with images when I've experienced that.

Armchair Anarchist's picture
Armchair Anarchist
Offline
Joined: 16-12-07
Apr 6 2012 14:28

Minor flaw only but at the bottom of threads the 'next' and 'last' links aren't level:

jolasmo
Offline
Joined: 25-12-11
Apr 7 2012 00:17

Just to say, now the Firefox issues are fixed I think the new theme looks fantastic. The old logo looks very out of place but I know you're going to change that anyway, so good work!

~J.

Chilli Sauce's picture
Chilli Sauce
Offline
Joined: 5-10-07
Apr 8 2012 09:49

So this is probably my being a dunce, but where have the 'related articles/threads' gone?

Also, when I check my profile, there's quite and unwielding 2 inch gap between my username and the rest of my profile information.

bulmer's picture
bulmer
Offline
Joined: 17-11-10
Apr 11 2012 04:46

The attachment descriptions for the library need to be have more space to the right of them because if you have a number at the end of them it makes it look as though the filesize is massive.

Look here for an example
http://libcom.org/library/marching-altogether-interview-member-leeds-fans-united-against-racism-fascism

It looks like this

Quote:
Marching Altogether No.152.87 MB
Marching Altogether No.162.69 MB
Steven.'s picture
Steven.
Offline
Joined: 27-06-06
Apr 11 2012 09:22

Thanks for pointing that out

Spassmaschine
Offline
Joined: 29-01-07
Apr 17 2012 12:43

Not sure if this is a known problem as my eyes glazed over reading the list, but the revisions block is hidden in the top right corner behind the "libcom is a resource for all people who.." block, kinda like how the profiles and tracker pages looked before that error was fixed. This is in Firefox 11.0

Spassmaschine
Offline
Joined: 29-01-07
Apr 17 2012 12:59
Spaßmaschine wrote:
Not sure if this is a known problem as my eyes glazed over reading the list, but the revisions block is hidden in the top right corner behind the "libcom is a resource for all people who.." block, kinda like how the profiles and tracker pages looked before that error was fixed. This is in Firefox 11.0

Hmm it doesn't seem to be a problem with all revisions; this one http://libcom.org/node/41063/revisions is where I had the problem, but http://libcom.org/node/41050/revisions for example works fine. The problematic one was a forum thread whereas the second one is a library article...don't know if that makes a difference..??

Steven.'s picture
Steven.
Offline
Joined: 27-06-06
Apr 22 2012 13:00

Tag intro displaying bug:
http://libcom.org/forums/feedback-content/tag-links-21042012

espanglish's picture
espanglish
Offline
Joined: 25-05-11
Apr 24 2012 21:35

Not sure if i can help out here but my living is made working in web (at one of the top agencies in the country) so would be happy to help if it's needed

Steven.'s picture
Steven.
Offline
Joined: 27-06-06
Apr 24 2012 22:19
espanglish wrote:
Not sure if i can help out here but my living is made working in web (at one of the top agencies in the country) so would be happy to help if it's needed

hey, thanks for the offer, we really appreciate it. What kind of stuff do you normally do?

Chilli Sauce's picture
Chilli Sauce
Offline
Joined: 5-10-07
Apr 25 2012 07:05

I'm having trouble when I go to My Recent Posts again. They're all hidden off on the far right side of the screen...

Steven.'s picture
Steven.
Offline
Joined: 27-06-06
Apr 25 2012 08:42

What browser?

Mike Harman
Offline
Joined: 7-02-06
Apr 25 2012 10:48

I changed this so that Felix Frost's fix only applied on /tracker pages - since it was breaking other pages in other browsers elsewhere. However it still works fine for me on /tracker, so yeah it'd be good to know which browser you're seeing it not working in.

Mike Harman
Offline
Joined: 7-02-06
Apr 25 2012 10:49

Oh wait 'my recent posts', that probably explains it...

Chilli Sauce's picture
Chilli Sauce
Offline
Joined: 5-10-07
Apr 25 2012 16:18

Sorry, should have been more specific.

> My account
> track

I'm using firefox 11.0 for ubuntu.

Chilli Sauce's picture
Chilli Sauce
Offline
Joined: 5-10-07
Apr 26 2012 16:15

Same thing happens when I try to access my private messages, too.

Croy's picture
Croy
Offline
Joined: 26-05-11
Apr 28 2012 13:11

Minor thing. When I have done a URL linkin to a blog at one point in my blog low down, when I publish it, it comes at the top above everything ever time

Steven.'s picture
Steven.
Offline
Joined: 27-06-06
Apr 28 2012 13:58
the croydonian anarchist wrote:
Minor thing. When I have done a URL linkin to a blog at one point in my blog low down, when I publish it, it comes at the top above everything ever time

do you mean in this blog?
http://libcom.org/blog/cctv-common-room-28042012

it looked liked the link to Joseph's article and your disclaimer was meant to be at the bottom of the text, so I just cut and pasted the text which was at the top of the article and put it at the bottom. This seems to have fixed it. This was definitely not an issue with the new theme.

Croy's picture
Croy
Offline
Joined: 26-05-11
Apr 28 2012 15:51

Id like the disclaimer to be at the top and the link where it says in brackets "read the article here" in brackets

Steven.'s picture
Steven.
Offline
Joined: 27-06-06
Apr 29 2012 14:27

If you just edit it you can cut and paste the text and put it where ever you like. An editor will approve your change.

Uncreative's picture
Uncreative
Offline
Joined: 11-10-09
Apr 29 2012 15:15

Im using Firefox 11.0, on ubuntu 11.10.

Same sort of problems as Chilli sauce. In the 'my account' section, the following sections are hidden on the right hand side.

bookmarks
track
the change email and password section in the account section in 'edit' (though the rest of account displays fine)
the contact section in 'edit'
personal section in 'edit'
networking and politics section in 'edit'